Welcome to Meridian - Age of Invention forum

Welcome to Meridian - Age of Invention forum. This is your place to discuss the game, share tips and tricks, and connect with other players.Have fun and keep playing!

Posted on Wed Feb 06 03:56:54 UTC 2013

I have been stuck on level 4 it just keeps going and going . Once you build the bridge the cart comes out and just spins around in circles. I played this level for 20 mins and the time ran out but it kept playing. delivering food and mail. Help

Posted on Thu Feb 07 04:58:03 UTC 2013

debbie61
 
12 posts
slimkim wrote: I have been stuck on level 4 it just keeps going and going . Once you build the bridge the cart comes out and just spins around in circles. I played this level for 20 mins and the time ran out but it kept playing. delivering food and mail. Help


You're getting further than me, I can't even get it to run. Downloaded 4 times, over 2 different browsers, trying both save and run options, it installs and then when I go to play the game it crashes. Meridian has stopped responding.

Tried playing as trial and funpass subscriber.

Posted on Thu Feb 07 07:11:49 UTC 2013

debbie61
 
12 posts
Just in case anyone else is having problems - I turned SLI off and the game is now running

Posted on Thu Feb 07 07:15:31 UTC 2013

Trillian
 
11 posts
debbie61 wrote: Just in case anyone else is having problems - I turned SLI off and the game is now running

Call me d'oh...but what is SLI and how do I shut it off? I'm having the same problem.

Posted on Thu Feb 07 17:46:03 UTC 2013

debbie61
 
12 posts
Trillian wrote:
debbie61 wrote: Just in case anyone else is having problems - I turned SLI off and the game is now running

Call me d'oh...but what is SLI and how do I shut it off? I'm having the same problem.


SLI is Scalable Link Interface which you can turn on when you have 2 Nvidia graphic cards.

If you right click on your desktop and seelct Nvidia Control Panel.
In the 3D settings group on the left you should see Configure SLI, Surround, PhysX
Click on this and on the right you should see a box for SLI configuration, select Disable SLI then apply.

ATI have something similar called CrossFireX, but I am not sure what the menu options are to turn it off.

Posted on Fri Feb 08 00:34:42 UTC 2013

trask51
 
10 posts
I am stuck on level 4 also, fixed the bridge and out came the cart and it was spinning in a circle. Did a replay and the same thing happened but I got the cart to move from one area to the next but it still sat there spinning and will not finish level. We need a fix for this.

Posted on Fri Feb 08 17:40:42 UTC 2013

I am having the exact same problem, so I uninstalled. Hope they fix this soon! You would think they'd catch a bug that occurs so early in the game.

Posted on Sat Feb 09 15:50:31 UTC 2013

Hey Admin have you spoken with the developers of this game yet? It would be nice to know if there is a fix in the near future. Alawar usually has great bug free games but this one seems to have jumped the gun on the release without proper vetting of game play. I only state this because most players seem to be having the same issues. Admin let us know something one way or the other please smilie

Posted on Wed Feb 13 21:21:53 UTC 2013


Debbie,

How do I find out if I have two Nvidia graphic cards? Forgive me, but PLEASE be specific. I am not fully computer literate. Also, what exactly does ATI mean?

Thank you in advance for any/all help you can give me. Unfortunately, I'm one of the people who bought this game because it looked like fun; and probably would be if I could get past Level 4. The spinning cart put a stop to that, though.

Linda

Posted on Sat Apr 06 23:43:00 UTC 2013

genie60
 
19 posts
this game is still not fixed. i have been waiting since it first came out for it to get fixed. why isnt anyone doing anything and letting us know if it is being addressed!!

Posted on Tue Jul 23 02:57:51 UTC 2013